1. Статьи
Заметки пользователей
14.11.2022 08:58
PDF
398
5

Хроники выживания нанооператора: собственная виртуальная АТС из земли и палок

Введение

Прежде всего, благополучие нанооператора зависит от экономии и грамотного распределения бюджета. Так как наша отрасль связана с людьми, то вводя режим экономии, мы должны помнить, как в конечном итоге это скажется на настроении абонента, который пользуется услугой. Телефон технической поддержки часто завязан на одного сотрудника. Возможно, компания предоставляет сотовый телефон или вторую sim-карту ответственному лицу. В таком решении содержится множество проблем, но часто нанооператоры идут на это с целью экономии. 

Представим себе обычную ситуацию — аварию на сети передачи данных, большое количество звонков приходится на одного сотрудника. Неудивительно, что через некоторое время оператор технической поддержки просто перестанет отвечать на телефон. Даже не учитывая базовые потребности человека: пообедать, сходить в туалет, погладить кошку.

Собственная виртуальная АТС из ничего

В качестве бесплатного решения и исправления неэффективного бизнес-процесса, можно использовать любой USB-модем, даже устарелый 3G, и систему переадресаций. В модем устанавливается sim-карта телефона сотрудника технической поддержки. Если нет такой возможности - ставится новая.

Хроники выживания нанооператора: собственная виртуальная АТС из земли и палок
Рисунок 1. Старый 3G модем и OTG кабель переходник

Логика настраивается по ситуации. Если произошла авария — включается сообщение: «Ведутся технические работы, возможен перерыв сервиса». В обычное время все входящие звонки компании переадресовываются на личные номера сотрудников по времени и проценту. Диапазон рабочего времени компании также указывается в алгоритме работы, чтобы оберегать сон сотрудников.

Настройка

Перейдем к самому главному — запуску АТС на модеме. В данном случае мы устанавливаем его в обычный MikroTik, через OTG-кабель. Но решение универсальное, можно использовать любые сервера на базе Linux. Последние версии модемов имеют собственную OS, позволяющую развернуть все на борту.

Хроники выживания нанооператора: собственная виртуальная АТС из земли и палок
Рисунок 2. Популярный MikroTik CCR1036 с OTG разъемом в левой части
Создаем на MikroTik шлюз передачи команд sim-карте:

 

/interface ppp-client add add-default-route=no dial-on-demand=no name=ppp-out1 port=usb3 use-peer-dns=no

Добавляем основной скрипт управления sim картой, назовем его script_sim:

#Block round

:local imp [/file get "imp.txt" content];

:if ([:len $imp]=0) do={:set imp 0};

:set imp ($imp+1);

:if ($imp>9) do={

        :set imp 1;

    }

/file set "imp.txt" contents=($imp);

 

 

#Block clock

:local start "10";

:local stop "21";

 

:local hour [:pick [/system clock get value-name="time"] 0 2];

 

:if ($hour>=$start && $hour<$stop) do={

    :log warning "Support [ON]";

 

    :if ($imp=1) do={

        /interface ppp-client info 0 user-comm="AT+CCFC=4,3,+79040000001" once do={:delay 5};

        :log warning "Phone support: Samoilov Anton Sergeevich";

    }

 

    :if (($imp=2)  or ($imp=3)) do={

            /interface ppp-client info 0 user-comm="AT+CCFC=4,3,+79080000002" once do={:delay 5};

            :log warning "Phone support: Bogdanov Nikolai Sergeevich";

        }

 

    :if (($imp=4)  or ($imp=5)) do={

            /interface ppp-client info 0 user-comm="AT+CCFC=4,3,+79530000003" once do={:delay 5};

            :log warning "Phone support: Petrov Alexander Valereivich";

        }

 

    :if  (($imp=6)  or ($imp=7)) do={

            /interface ppp-client info 0 user-comm="AT+CCFC=4,3,+79510000004" once do={:delay 5};

            :log warning "Phone support: Napadailo Alexander Petrovich";

        }

    :if  (($imp=8)  or ($imp=9)) do={

            /interface ppp-client info 0 user-comm="AT+CCFC=4,3,+79080000005" once do={:delay 5};

            :log warning "Phone support: Koshevnikova Anna Sergeevna";

        }

 

  } else={

    :log warning "Support [OFF] => Ne rabochee vremia!";

    /interface ppp-client info 0 user-comm="AT+CCFC=4,3,+79001234567" once do={:delay 5};

    :log warning "Phone support: Avtootvetchik";

  }

 

Рассмотрим, созданный скрипт. Во время запуска, на файловом диске создается текстовый документ imp. txt с порядковым числом этапа выполнения скрипта. В данном случае максимальным числом этапов может быть восемь, на девятом этапе происходит переадресация на первый. Далее, по коду блока времени, установлены рабочие часы технической поддержки с 10 до 21 часа. Следующим шагом описаны сотрудники - их пять человек. У первого специалиста задано всего 10% всех звонков, так как ему присвоен всего один этап, у остальных - по два. В конце установлен телефон ночного дежурного или заглушка с сообщением о времени работы техподдержки. Стилистика кода, на первый взгляд, достаточно простая. Скрипт отлажен, имеет набор исправлений по ходу эксплуатации, является на 100% рабочим и надежным, легко правится под любой алгоритм.

На маршрутизаторе MikroTik создается планировщик заданий с временем выполнения скрипта script_sim раз в 15 минут. В зависимости от заданного времени, настраивается периодичность переадресации на других сотрудников технической поддержки:

/system script run script_sim;

Также, необходимо добавить скрипт на экстренный случай. Он выполняется если произойдет авария. Назовём его script_teh_raboti:

/system scheduler disable [/system scheduler find where name=schedule_sim];
/interface ppp-client info 0 user-comm="AT+CCFC=0,0″ once do={:delay 5};

Включение script_teh_raboti отключает планировщик по запуску script_sim и удаляет все переадресации с sim-карты. На все входящие звонки будут только гудки.

Лайфхак

Интересное решение состоит в озвучивании голосового сообщения в ответ на входящие звонки при аварии или ведении работ на линиях связи. Для этого подключается услуга «Замени гудок на любую мелодию» у сотового оператора. В личном кабинете загружается звуковой файл с любым голосовым сообщением. Данное сообщение будет воспроизводиться при условии отключения всех переадресаций на sim-карте, абонент будет дозваниваться на модем и слушать ранее загруженный файл с информацией о плановых работах. С включенной переадресацией услуга «гудок» не работает.

Универсальность

Разберем плюсы. Скрипты легко интегрируются в работу маршрутизатора. Клиент может быть уведомлен о неполадке быстрее вас - допустим, при разрыве связи от вышестоящего провайдера. Отсутствие обслуживания АТС. Ежемесячные расходы - менее тысячи рублей. Во время звонка сотрудник всегда видит реальный номер телефона звонящего, в отличии от многих коммерческих АТС. Мобильный оператор предоставляет два номера городской и мобильный к которому абоненты в последнее время более лояльны. Внесение изменений на лету, если какой-то технический специалист ушел в отпуск или появился новый сотрудник - правка займет несколько секунд.

Мои наблюдения

Проводя разные эксперименты с «умными» роботами-операторами и интегрируя интерактивные меню, я пришел к выводу, что для нанооператора и абонента было бы лучше, если отвечать на звонки будет сотрудник техподдержки. Если нет возможности ответить, лучше сообщить, когда такая возможность появится. 

Чем меньше мы раздражаем абонента и тратим его время, тем лучше.

5 комментариев
Robot_NagNews
Robot_NagNews
Материал: Прежде всего, благополучие нанооператора зависит от экономии и грамотного распределения бюджета. Полный текст
Гость
Гость
Как вы все любите костыли городить вместо того чтобы сделать нормально. Даже если вы нано-оператор, у вас сервера на Линуксе нету что ли? Ну конечно есть же. Что же мешает поставить туда полноценную АТС и сделать сразу как это должно быть. Потом вот в это все растет, костылей становится все больше и получаем в итоге уже не нано-оператора, но сделанного вот таким способом.. В конце концов, туда приходит нормальный инженер и у него горит от вот такого трэшака.
Гость
Гость
Реально какая-то жесть.
Есть бесплатные АТС для Linux, почему бы не сделать нормально ?
Зачем такие костыли ?
Стич
Стич

Ну тогда уж берётся один сервер на Linux и на нем делается bras, биллинг, asterisk, nagios.

Ну и вообще в современных условиях юзать MikroTik мягко говоря не очень.

 

Ivan_83
Ivan_83

Технопорно детектед :)

 

 

Оно конечно интересно, но.

 

1. Проще было взять нечто в облаке и прицепить туда какой то номер по сип от мегафона, чтобы не стать рабом облачной атс из за привязки к их номеру.

 

2. Можно было поставить астериск или freepbx (типа замена астериска) и всё тот же номер мегафона через сип заюзать. Тазика там достаточно любого, хоть роутер на опенврт, но лучше х86 с обычной убунтой - так проще суппортить. Для атс этих есть вебгуи, если хочется мышковзить диалпланы а не руками редактировать конфиги.

 

3. Секс с микротиком сильно хуже секса с опенврт, если уж совсем собирать из того что куплено от сдачи бутылок.

 

 

У п1 и п2 бонусом обычно есть аналитика и запись звонков. В п2 можно накрутить всяких извратов, типа голосовых меню и пр.