vk_logo twitter_logo facebook_logo googleplus_logo youtube_logo telegram_logo telegram_logo

#236 Знак качества. Cisco QoS для начинающих III

Дата публикации: 31.07.2005
Количество просмотров: 21339

 

23 июля 2005 года на 48-ом году жизни скоропостижно скончался бессменный руководитель группы компаний "Демос" Сергей Петрович Бородько - отец-основатель российского Интернета.

Разное.

Сегодня вопрос первого абзаца даже не стоял. Безусловно, главное событие недели - день сисадмина. Поздравляю! Желаю больше хорошего пива, симпатичных девушек, и такой работы, чтоб понедельник начинался в субботу.

Кстати, о понедельнике. С завтрашнего дня (1 августа) уральский монополист (Уралсвязьинформ, УСИ), решил начать ADSL атаку на потребительский рынок. Заявлены новые тарифы. И уже есть превентивная реакция сетей-конкурентов.

Легко видеть, что предложенные Ethernet'чиками цены на четверть меньше, к тому же подразумевают недорогой внутрисетевой трафик ресурсов типа p4p, на котором доступно порядка 50 Терабайт фильмов, музыки, вареза, и прочего ххх... Впрочем, сейчас редкая сеть обходится без десятка терабайт "своего" контента...

Остальные провайдеры еще не "прореагировали", но вероятно в ближайший месяце сводная таблица цен претерпит ощутимые изменения. Но - только локального характера - снижение тарифов вряд ли будет большим, чем на 20-30%.

Таким образом, уже видны два "следствия".

Во-первых, начальный натиск АДСЛ от УСИ будет выливаться в вязкую конкурентную борьбу на почти одинаковых тарифах. Плюсы АДСЛ известны, они есть. Но и минусов хватает. Так что до конца года (либо ввода новых тарифов) ничего не изменится, АДСЛ будет планомерно набирать клиентов (в основном с малоэтажных сетевых "неудобий") и выстраивать саппорт. Ожидаемое количество подключений - несколько сотен в месяц. "Стрима" не будет.

И во-вторых, для конечного пользователя внутригородской трафик умер. Главный киллер этого явления - УСИ. Как бы невелико было влияние Уралсвязьинформа на рынок сейчас, вес и возможности компании велики. И ей не выгодно через узкие (относительно) каналы DSL продавать дешевый тяжелый трафик. Намного привлекательнее каналы в 128-256к, но они пока в Екатеринбурге стоят неразумные деньги.

С другой стороны, внутригород стал не нужен и крупным Ethernet-провайдерам. Они приближаются к общегородскому охвату, и вполне самодостаточны (десятки терабайт своего тяжелого контента). Перейти на плоскую шкалу с понятными тарифами, сохранив дешевый внутрисетевой трафик - очень достойный ответ на угрозу АДСЛ.

Пострадают при этом очень узкие категории пользователей. В основном - небольшие местные хостеры, сориентированные на дешевый "внутригород", да продавцы "проксей" - т.е. трафика, "уворованного" из сетей местного университета. Среднему абоненту все только в радость - новый серьезный игрок на рынке неизбежно опустит уровень цен...

Кстати, изменения далеко не локальны. С августа стартуют новые тарифы УСИ в Челябинске. Там пока за массовый рынок всерьез не берутся - для начала душат субпровайдеров. Для этого убрали дисконты при объемах трафика более 100 Гигабайт. Но и про частников не забывают - введен новый тариф за 500 рублей в месяц (включено 200 Мб), до него 1000 рублей были необходимым минимумом.

Так что АДСЛ имени Связьинвеста набирает разгон. Зевать нельзя...

 


Немного юмора.

   

Стоимость труда

         Вот так мебельные компании ищут системных администраторов...

Нужно заметить, что 200грн - около $40. Ну а то, что оплата сисадмина и уборщицы одинаковая - вообще навевает мысли о слабой вменяемости работодателей.

Прислал скан Алексей, ведущий инженер-программист ОАО "ИТЭК"

 


Ссылки.

Совершенно очаровательная статья Скандал с отмыванием денег в немецком Commerzbank.
По данным немецкой Frankfurter Ruhdschau, жена Путина и министр связи Рейман одно время фигурировали в ведомости на выдачу зарплаты компании "Телекоминвест", которую немецкие власти считают главным звеном в цепи по отмыванию денег.
Добавить тут нечего.

Надо же придумать спрей для повышения скорости Wi-Fi... Wi-Fi Speed Spray.
"I really didn't think it would work, but now I'm a believer. I just ordered another case of WiFi Speed Spray™ and I recommend it to all of my friends." - Ted Smith, New York
Качественная "обманка" - contains 99% water, 1% secret ingredient. Даже схема "работы" есть, и три жутких формулы.

Межоператорская конкурентная борьба по Эстонски. Тихо, почти по домашнему... :-)

Почему в России так дорог трафик. Резюме просто и незатейливо - стоит много потому что дешевле и быть не может. Впрочем, все объясняет следующая цитата:
...Об основных тенденциях и особенностях сегмента в интервью CNews рассказал - старший вице-президент компании "ТрансТелеКом" Алексей Рокотян...

Немного фотографий зарубежных дата-центров. А тут - галерея фотографий российской домашней сети.

Интересные графики загрузки каналов от Искрателеком.

Еще один проект IP-телефонии. Основан на полуторагодичной эксплуатации, постоянно развивается... Даже не думал, что у Skype столько конкурентов.

 


Обновление в разделах:

Оптическая муфта из свитча Acorp

... В одном из мест сети оптоволоконный кабель проходит по столбам через дорогу. После обрыва большегрузом появилась необходимость его сварить - с минимальными затратами.

Варка оптики

Варка оптики

 

Прислал Александр Муравьев

Знак качества. Cisco QoS для начинающих. Продолжение.

3.3. Предотвращение перегрузок (Congestion avoidance).
 3.3.1. RED
 3.3.2 ECN

3.3. Предотвращение перегрузок (Congestion avoidance).

3.3.1. RED

Random Early Detection (RED) используется в скоростных сетях для предупреждения перегрузок. Затрагивает только TCP. Путем отбрасывания случайным образом пакетов из наиболее мощных потоков вынуждает посылающую сторону уменьшить скорость передачи (используя соответствующие свойства TCP протокола - окно перегрузки, Congestion Window). Доля отбрасываемых пакетов регулируется при конфигурации.

Алгоритм настройки.

Настройка заключается в активации RED на интерфейсе.

interface FastEthernet0/0
 random-detect

3.3.2 ECN

Explicit Congestion Notification (ECN) использует ту же логику, что и RED, но не отбрасывает пакеты, а уведомляет о необходимости ограничения, маркируя их (устанавливает в IP заголовке ECN биты).

3.4. Регулирование интенсивности.

3.4.1. Layer 2 Регулирование интенсивности.

Современные коммутаторы позволяют регулировать интенсивность трафика несколькими способами.

Flow control предназначен для детектирования и сигнализации передающей стороне о превышении скорости поступления пакетов.

Storm control ограничивает предельное значение скорости пакетов на интерфейсе, выше которого будет происходить отбрасывание.

Bandwidth чаще всего дискретно регулирует полосу пропускания на портах.

3.4.2. Layer 3 Регулирование интенсивности.

3.4.2.1. Police.

Ограничитель (Policer) соответственно ограничивает поток трафика до нужной величины методом простого отбрасывания пакетов, поступающих с выходящей за рамки скоростью. Может работать как на входящем, так и на выходящем интерфейсах. Кратко можно охарактеризовать как ОГРАНИЧИТЕЛЬ интенсивности методом ОТБРАСЫВАНИЯ при превышении заданной скорости.

Рисунок 1

Назначение применения: ограничение трафика до скорости контракта, то есть управление интенсивностью. Следует отметить, что ограничение трафика может помочь и в случае предотвращения DOS атак.

Область применения: как на входных, так и на выходных портах. Чаще всего на входных, так как в этом случае отбрасываемые пакеты не доходят до процесса маршрутизации и таким образом экономятся ресурсы. К ограничителям трафика относится механизм Committed Access Rate (CAR).

Параметры команды.

CAR

rate-limit {input|output} access-group ACCESS_LIST BIT_RATE BURST_NORMAL BURST_MAX conform-action ACTION exceed-action ACTION

POLICE

police BIT_RATE BURST_NORMAL BURST_MAX conform-action ACTION exceed-action ACTION

обозначения:

ACCESS_LIST – аксесс лист классификации

BIT_RATE – допустимая скорость (bit/s)

BURST_NORMAL – размер всплеска (в байтах)

BURST_MAX – максимальный размер всплеска (в байтах)

conform-action ACTION – действие при соответствии ограничению:

 drop – уничтожить
 transmit - передать
 set-dscp-transmit – пометить пакет

exceed-action ACTION - действие при превышении ограничения:

 drop – уничтожить
 transmit - передать
 set-dscp-transmit – пометить пакет

Пример 1.

CAR ограничение UDP до 8 кбит, TCP и ICMP до 80 кбит.

!
interface Ethernet0/1
 ip address 192.168.0.5 255.255.255.252
 rate-limit output access-group 100 8000 2000 2000 conform-action drop exceed-action drop
 rate-limit output access-group 101 80000 8000 8000 conform-action drop exceed-action drop
 full-duplex
 priority-group 1
 no cdp enable
!
access-list 100 permit udp any any
access-list 101 permit tcp any any
access-list 101 permit icmp any any
!

Пример 2.

CAR ограничение трафика клиента 192.168.0.2 до 128 kbit/s со стороны ISP.

Рисунок 2

!
interface FastEthernet0/0
 description INTERNET
 ip address 194.226.248.67 255.255.255.252
 rate-limit output access-group 101 128000 8000 8000 conform-action transmit exceed-action drop
 no cdp enable
!
interface FastEthernet0/1
 description CLIENT
 ip address 192.168.0.1 255.255.255.252
 rate-limit output access-group 102 128000 8000 8000 conform-action transmit exceed-action drop
!
access-list 101 permit ip host 192.168.0.2 any
access-list 102 permit ip any host 192.168.0.2
!

Пример 3.

Police ограничение трафика клиента 192.168.0.2 до 128 kbit/s со стороны ISP.

Рисунок 3

!
class-map match-all Traf1
 match access-group 101
!
!
class-map match-all Traf2
 match access-group 102
!
policy-map Policy1
 class Traf1
 police 128000 8000 8000 conform-action transmit exceed-action drop
!
policy-map Policy2
 class Traf2
 police 128000 8000 8000 conform-action transmit exceed-action drop
!
interface FastEthernet0/0
 description INTERNET
 ip address 194.226.248.67 255.255.255.252
 service-policy output Policy1
 no cdp enable
!
interface FastEthernet0/1
 description CLIENT
 ip address 192.168.0.1 255.255.255.252
 service-policy output Policy2
 no cdp enable
!
access-list 101 permit ip host 192.168.0.2 any
access-list 102 permit ip any host 192.168.0.2
!

3.4.2.2. Shaping.

Формирователь (шейпер, Shaper) обычно задерживает исходящий трафик, используя буфер или механизм очередей, формируя поток с нужными параметрами. Выполняет функции сглаживания. Применяется для ограничения пропускной способности на выходе из интерфейса. Кратко можно охарактеризовать как ОГРАНИЧИТЕЛЬ- ВЫРАВНИВАТЕЛЬ интенсивности методом ЗАДЕРЖКИ (буферизации пакетов) и дальнейшей пересылки с согласованной интенсивностью при превышении заданной скорости. Декларируется, что шейпинг более дружественен к TCP, чем полисинг.

Рисунок 4

Назначение применения:

1. В случае, если где-то далее в сети применяется полисинг, который, как известно, приводит к отбрасыванию пакетов. Лучше заранее на подходах “мягко” ограничить трафик перед полисингом.

2. В случае, если где-то далее в сети возможно переполнение входных очередей, а QoS там не настроен или невозможен.

3. Ограничение скорости доступа до контрактных значений.

Область применения: всегда на выходном интерфейсе.

Параметры команды.

traffic-shape group ACCESS_LIST BIT_RATE BURST_SIZE EXCESS_BURST_SIZE BUFFER_LIMIT

обозначения:

ACCESS_LIST – аксесс лист классификации

BIT_RATE – допустимая скорость (bit/s)

BURST_SIZE – размер всплеска (в байтах), по умолчанию равен BIT_RATE/8

EXCESS_BURST_SIZE – превышение размера всплеска (в байтах), по умолчанию равен BURST_SIZE

BUFFER_LIMIT – размер буфера

Пример 1.

Ограничение UDP до 8 kbit/s.

!
interface Ethernet0/1
 ip address 192.168.0.5 255.255.255.252
 full-duplex
 traffic-shape group 100 8000 1500 2000 1000
 no cdp enable
!
access-list 100 permit udp any any
!

Пример 2.

Ограничение UDP до 8 kbit/s, TCP и ICMP до 14 kbit/s.

!
interface FastEthernet0/0
 ip address 192.168.0.5 255.255.255.252
 traffic-shape group 101 8000 2000 2000 2000
 traffic-shape group 102 14000 2000 2000 2000
 no cdp enable
!
access-list 101 permit udp any any
access-list 102 permit tcp any any
access-list 102 permit icmp any any
!

#sh traffic-shape FastEthernet0/0

Пример 3.

Ограничение TCP и ICMP до 64 kbit/s.

!
class-map match-all Traf1
 match access-group 102
!
policy-map Policy1
 class Traf1
  shape peak 64000
!
!
interface FastEthernet0/0
 ip address 192.168.0.2 255.255.255.252
 no cdp enable
!
interface FastEthernet0/1
 ip address 192.168.0.5 255.255.255.252
 service-policy output Policy1
 no cdp enable
!
access-list 102 permit tcp any any
access-list 102 permit icmp any any
!

Пример 4.

Ограничение трафика клиента 192.168.0.2 до 128 kbit/s со стороны ISP.

Рисунок 5

!
interface FastEthernet0/0
 description INTERNET
 ip address 194.226.248.67 255.255.255.252
 traffic-shape group 101 128000 7936 7936 1000
  no cdp enable
!
interface FastEthernet0/1
 description CLIENT
 ip address 192.168.0.1 255.255.255.252
 traffic-shape group 102 128000 7936 7936 1000
!
access-list 101 permit ip host 192.168.0.2 any
access-list 102 permit ip any host 192.168.0.2
!

Пример 5.

Ограничение трафика клиента (до 64 kbit/s) со стороны ISP.

Рисунок 6

!
class-map match-all Traf1
 match access-group 101
!
!
class-map match-all Traf2
 match access-group 102
!
policy-map Policy1
 class Traf1
  shape peak 64000
!
policy-map Policy2
 class Traf2
  shape peak 64000
!
interface FastEthernet0/0
 description INTERNET
 ip address 194.226.248.67 255.255.255.252
 service-policy output Policy1
 no cdp enable
!
interface FastEthernet0/1
 description CLIENT
 ip address 192.168.0.1 255.255.255.252
 service-policy output Policy2
 no cdp enable
!
access-list 101 permit ip host 192.168.0.2 any
access-list 102 permit ip any host 192.168.0.2

 


Окончание следует...

Автор статьи Эдуард Афонцев

Анонс

 

  • Знак качества. Cisco QoS для начинающих, окончание. Edward Afontsev.

 

  • Узел 10-ти домов, как часть MAN;
  • Установка D-Link 2000AP;
  • Письмо про IPv6;
  • Восстанавливаем Linksys WRT54G;
  • Помехи на спектроанализаторе;
  • Фотография из серии "Жизнь";
  • Зарисовки узлов разных провайдеров. Вечная тема (много фотографий гарантировано);
  • Традиционный пункт - ссылки на интересные места Сети. Присылайте письма - они очень нужны для обзоров. Обязательно сообщайте, нужна ли Ваша подпись, ссылка, или лучше обойтись без нее;
  • В "ужастиках" - узел связи в одном из уральских санаториев.
От редакции: если у вас есть чем поделиться с коллегами по отрасли, приглашаем к сотрудничеству
Ссылка на материал, для размещения на сторонних ресурсах
/articles/reviews/15469/znak-kachestva-cisco-qos-dlya-nachinayuschih-iii.html

Обсудить на форуме

Оставлять комментарии могут только зарегистрированные пользователи

Зарегистрироваться