vk_logo twitter_logo facebook_logo googleplus_logo youtube_logo telegram_logo telegram_logo

#235 Знак качества. Cisco QoS для начинающих II

Дата публикации: 24.07.2005
Количество просмотров: 34440

А так же кроссворды и колонка юмора.
© м/ф Мадагаскар

Разное.

Старая истина - 80% работы занимают 20% времени. Остальное уходит на мелочи... Так и раздел, посвященный провайдерам Екатеринбурга, пришлось править всю прошлую неделю, и конца этому процессу не заметно. Поэтому ничего не остается, кроме как продолжить прием поправок и пожеланий.

Обзор начну со ссылок - интересные они подобрались на этой неделе.

Главный спамер России убит в собственной квартире. Без комментариев.

Очередной отчет о состоянии телекоммуникационного рынка выпустил J'son & Partners. Прочитать надо, но революционных изменений там не отражено.
Впрочем, запомнилась следующая цитата:
Документальная электросвязь становится одним из локомотивов роста телекоммуникационной отрасли в целом - она обеспечила 22% от общего прироста доходов от услуг связи (44 млрд. руб.) в I квартале 2005 г. по сравнению с I кварталом 2004 г. Вклад документальной электросвязи меньше вклада сотовой связи (46%), но больше вклада любой другой отрасли, включая проводную телефонию (17%).

Как-то незаметно передача данных обогнала священную корову Связьинвеста. Соответственно, надо ждать смешения акцентов в политике монополии, со всеми вытекающими конкурентными последствиями.

Собственно, изменения уже давно идут. Например "ЮТК" приступила к продвижению бренда DISEL. Это так маркетологи назвали доступ через АДСЛ. Кстати, на сегодняшний день в "ЮТК" смонтировано 36,2 тыс. портов АДСЛ, прирост с начала 2005 года составил 7,1 тыс. портов.

Количество "не внушает" даже для одного крупного города. Тем более на масштабе "ЮТК", у которой 3,9 млн. телефонных абонентов и 3 448 АТС. Но движение есть - для бренда создан единый портал, предложены вполне демократичные цены (абонплата 500 рублей в месяц, трафик в районе 1,5 рублей за мегабайт).

В принципе, ничего особенного, способного потрясти рынок, нет. Просто носорог начал разбег. А при его размерах хорошее зрение необязательно.

Можно добавить, что к осени должен стартовать широкомасштабный проект АДСЛ на Урале (Уралсвязьинформ). Бренд и тарифы пока неизвестны... Но намерения самые серьезные - Связьинвест за передачу данных будет браться всерьез.

 


Несколько фотографий - для улучшения настроения. Серия называется "эволюция ключниц".

Первые - "пионерские", из столешниц, сначала одна, через два года другая.

Эволюция ключниц

Вторая - настенный плоский шкаф с дверцами. Резервов хватило только на год.

Эволюция ключниц

Третья - тоже настенная, но использующая объём. Повешены 3 модуля, в каждом модуле по 6 вертикальных выдвигающихся палет. На каждой палете по 168 (в сумме, с обоих сторон) оцинкованных гвоздей для вагонки. Пока хватит. В случае чего можно дозаказывать модули.

Эволюция ключниц Эволюция ключниц

 


Продолжим осмотр ссылок.

Кино через интернет: Голливуд открывает доступ. Можно сказать, лед тронулся. Медленно, со скрипом, но производители видео-контента начали поворачиваться лицом в сторону интернет. Правда пока виден все больше недовольный капиталистический оскал...

Мининформсвязи открыло "телефон доверия". Уж не знаю, может это по мнению чиновников способно компенсировать приостановление действия новых правил присоединения...

Ещё один VoIP-клиент, призванный конкурировать со Skype - Freshtel. Основные его плюсы - меньшая загрузка процессора по сравнению со Skype, поддержка SIP-протокола. Минусы - поздний старт и поэтому призрачные шансы на заметную долю рынка.
Ссылку прислал Чучанов Сергей.

Фильм, подготовленный провайдером Aviel к дню предпринимателя. Объем файла около 50 мегабайт - так что качать осторожно.
Прислал Мигунов.

Укртелеком хочет денег за мою работу.... Обсуждается позиция Укртела по поводу использования офисных миниАТС, которые были самостоятельно куплены и установлены клиентом.
Оказывается за это надо платить. Привожу цитату:
Сегодня получили письмо от указанной конторы с требованиями оплатить за каждый внутренний номер с правом выхода на городскую телефонную сеть по 167 грн и далее каждый месяц платить абонплату. Всё аргументировано новыми тарифами и постановлениями КМУ, Госкомсявязи и т.д., и с угрозой И самое интересное Укртелеком не вложил в установку, настройку мини АТС и прокладку внутренних номеров ни копейки и просто берёт деньги за мою работу т.к. я работаю админом, и мини АТС в моём ведении.

 


Это учебная лаборатория Cisco в Талине, Эстония. На стенде 2600 серии Cisco роутеры + свитчи.

Учебная лаборатория Cisco
Прислал Sergei

 


Забавная статья на тему triple play в Азии. Так как написано на вражеском языке - привожу краткий перевод.

В азиатских странах triple play последнее время буквально не сходит с новостных лент. Пользователи уже предвкушают новую услугу, но для провайдеров все не так просто.

Во-первых, настоящую сеть triple play на базе IP довольно проблематично построить. В Азии можно найти всего несколько компаний, сделавших это реально. Большинство операторов до сих пор не могут полноценно объединить хотя бы две услуги.

Во-вторых, качество предоставляемых услуг будет сильно зависеть от платформы IPTV. По мнению аналитиков, провайдерам потребуется как минимум год, чтобы протестировать оборудование и определиться в выборе. Тестерами скорее всего будут пользователи DSL и КТВ. Так как IPTV требует как минимум 6 Мбит/с, первыми пользователями triple play станут жители Кореи, Японии и Гонконга, которые подключены к Интернету со скоростью 10Мбит/с и выше.

Ещё одним препятствием к triple play является цена оборудования для конечного потребителя. Совсем недавно компания Time Warner предложила triple play сеть с полным комплексом обслуживания в Орландо и Флориде. Однако всё остановилось из-за $500 приставки и неуклюжего интерфейса.

Тем не менее, существуют и положительные примеры. PCCW, крупнейший телекоммуникационный провайдер Гонконга, запустил NOW TV сервис для своих DSL клиентов еще в сентябре 2003. На сегодняшний день услуга NOW TV, награжденная несколькими индустриальными наградами, является образцом IPTV сервиса.

Еще хуже дела обстоят с универсальным блоком, который должен объединить широкополосную сеть провайдера с домашними Wi-Fi, Bluetooth и другими сетями, которые позволили получить дома полноценные triple-play услуги на все медийные устройства. Пользователь уже готов покупать, но... На сегодняшний день ни одна компания не может предоставить такую приставку за разумные деньги.

Причем эта проблема отнюдь не технического характера, как может показаться на первый взгляд. Дело в том, что компьютерная приставка должна быть главным устройством в домашней сети, способным связывать как проводные, так и беспроводные сети от всевозможных провайдеров и компаний. Поэтому пока такие гиганты как Motorola и NDS (производство set-top box), Sony и Samsung (производство бытовой электроники), производители ОС типа Microsoft, телефонные и кабельные компании не придут к общему мнению, конечному пользователю будут доставаться решения и устройства, работающие в очень ограниченном диапазоне.

По мнению экспертов, в самом ближайшем будущем разгорится очень ожесточенная борьба среди этих компаний за влияние на triple-play рынке. Пока же провайдеры занимаются суммированием приложений, которые они могут хоть как-то запустить на своих широкополосных сетях. Результат часто дорог и сложен в использовании.

А люди хотят чего-то простого. Поэтому технология должна эволюционировать в точку, где все происходит автоматически при нажатии лишь одной кнопки как на выключателе света, утверждает Jeffrey Soong, главным администратор компании BNS Ltd, специализирующийся на консультировании и системном интегрировании в области IPTV.

Не смотря на все перечисленные сложности и проблемы, рынок triple-play услуг очень перспективен. Jeffrey Soong говорит, что triple-play является "первой и самой главной защитой для провайдеров". Очевидность этого утверждения можно проследить по количеству пользователей PCCW. В начале 2003, когда ещё не были запущены полноценные IPTV услуги, потери составляли 27,000 пользователей в месяц. Однако к марту 2005, после запуска NOW TV, PCCW имела 450,000 IPTV пользователей.

 


Такая вот карманная "пинговалка" с Linux на борту. Называется Sharp Zaurus SL-C700.

Пинговалка

Пинговалка

Можно просто шлюз пропинговать, а можно и nmap"ом сегмент просканировать. На этой игрушке есть ssh и vnc клиенты, но это далеко не предел - при желании можно хоть апач с php установить, только тормозить будет. Идеально подходит для ремонтно-отладочных работ.
Прислал Terbo

 


Обновление в разделах

 


Сушка оптических разъемов с помощью подручного оборудования.

Знак качества. Cisco QoS для начинающих. Продолжение

3.2.3. Layer 3 Queuing.
 3.2.3.1. FIFO.
 3.2.3.2. PQ.
 3.2.3.3. CQ.
 3.2.3.4. WFQ.
 3.2.3.5. CBWFQ.
 3.2.3.6. LLQ.

3.2.3. Layer 3 Queuing.

Маршрутизирующие устройства оперируют пакетами на третьем уровне OSI (Layer 3). Чаще всего поддержка очередей обеспечивается программно. Это означает в большинстве случаев отсутствие аппаратных ограничений на их число и более гибкое конфигурирование механизмов обработки. Общая парадигма QoS Layer 3 включает маркировку и классификацию пакетов на входе (Marking & Classification), распределение по очередям и их обработку (Scheduling) по определенным алгоритмам.

Рисунок

И еще раз подчеркнем, что приоритезация (очереди) требуется в основном только в узких, загруженных местах, когда пропускной способности канала не хватает для передачи всех поступающих пакетов и нужно каким-то образом дифференцировать их обработку. Кроме того, приоритезация необходима и в случае предотвращения влияния всплесков сетевой активности на чувствительный к задержкам трафик.

Проведем классификацию Layer 3 QoS по методам обработки очередей.

3.2.3.1. FIFO.

Элементарная очередь с последовательным прохождением пакетов, работающая по принципу  первый пришел – первый ушел  (First In First Out - FIFO), имеющему русский эквивалент  кто первый встал того и тапки . По сути, здесь нет никакой приоритезации. Включается по умолчанию на интерфейсах со скоростью больше 2 мбит/с.

3.2.3.2. PQ. Очереди приоритетов.

Priority Queuing (PQ) обеспечивает безусловный приоритет одних пакетов над другими. Всего 4 очереди: high, medium, normal и low. Обработка ведется последовательно (от high до low), начинается с высокоприоритетной очереди и до ее полной очистки не переходит к менее приоритетным очередям. Таким образом, возможна монополизация канала высокоприоритетными очередями. Трафик, приоритет которого явно не указан, попадет в очередь по умолчанию (default).

Параметры команды.
распределение протоколов по очередям:
priority-list LIST_NUMBER protocol PROTOCOL {high|medium|normal|low} list ACCESS_LIST_NUMBER
определение очереди по умолчанию:
priority-list LIST_NUMBER default {high|medium|normal|low}
определение размеров очередей (в пакетах):
priority-list LIST_NUMBER queue-limit HIGH_QUEUE_SIZE MEDIUM_QUEUE_SIZE NORMAL_QUEUE_SIZE LOW_QUEUE_SIZE

обозначения:
LIST_NUMBER – номер обработчика PQ (листа)
PROTOCOL - протокол
ACCESS_LIST_NUMBER – номер аксесс листа
HIGH_QUEUE_SIZE – размер очереди HIGH
MEDIUM_QUEUE_SIZE - размер очереди MEDIUM
NORMAL_QUEUE_SIZE - размер очереди NORMAL
LOW_QUEUE_SIZE - размер очереди LOW

Алгоритм настройки.

1. Определяем 4 очереди
access-list 110 permit ip any any precedence network
access-list 120 permit ip any any precedence critical
access-list 130 permit ip any any precedence internet
access-list 140 permit ip any any precedence routine

priority-list 1 protocol ip high list 110
priority-list 1 protocol ip medium list 120
priority-list 1 protocol ip normal list 130
priority-list 1 protocol ip low list 140
priority-list 1 default low

Дополнительно можно установить размеры очередей в пакетах
priority-list 1 queue-limit 30 60 90 120

2. Привязываем к интерфейсу

!
interface FastEthernet0/0
 ip address 192.168.0.2 255.255.255.0
 speed 100
 full-duplex
 priority-group 1
 no cdp enable
!

3. Просмотр результата
# sh queueing priority

Current priority queue configuration:

List Queue Args - -
1 low default -
1 high protocol ip list 110
1 medium protocol ip list 120
1 normal protocol ip list 130
1 low protocol ip list 140

#sh interfaces fastEthernet 0/0

Queueing strategy: priority-list 1

#sh queueing interface fastEthernet 0/0
Interface FastEthernet0/0 queueing strategy: priority

Output queue utilization (queue/count)
  high/19 medium/0 normal/363 low/0

3.2.3.3. CQ. Произвольные очереди.

Custom Queuing (CQ) обеспечивает настраиваемые очереди. Предусматириваетмя управление долей полосы пропускания канала для каждой очереди. Поддерживается 17 очередей. Системная 0 очередь зарезервирована для управляющих высокоприоритетных пакетов (маршрутизация и т.п.) и пользователю недоступна.

Очереди обходятся последовательно, начиная с первой. Каждая очередь содержит счетчик байт, который в начале обхода содержит заданное значение и уменьшается на размер пакета, пропущенного из этой очереди. Если счетчик не ноль, то пропускается следующий пакет целиком, а не его фрагмент, равный остатку счетчика.

Параметры команды.
определение полосы пропускания очередей:
queue-list LIST-NUMBER queue QUEUE_NUMBER byte-count
BYTE_COUT

определение размеров очередей:
queue-list LIST-NUMBER queue QUEUE_NUMBER limit QUEUE_SIZE

обозначения:
LIST-NUMBER – номер обработчика
QUEUE_NUMBER – номер очереди
BYTE_COUT – размер очереди в пакетах

Алгоритм настройки.

1. Определяем очереди
access-list 110 permit ip host 192.168.0.100 any
access-list 120 permit ip host 192.168.0.200 any

queue-list 1 protocol ip 1 list 110
queue-list 1 protocol ip 2 list 120
queue-list 1 default 3

queue-list 1 queue 1 byte-count 3000
queue-list 1 queue 2 byte-count 1500
queue-list 1 queue 3 byte-count 1000

Дополнительно можно установить размеры очередей в пакетах
queue-list 1 queue 1 limit 50
queue-list 1 queue 2 limit 50
queue-list 1 queue 3 limit 50

2. Привязываем к интерфейсу
!
interface FastEthernet0/0
 ip address 192.168.0.2 255.255.255.0
 speed 100
 full-duplex
 custom-queue-list 1
 no cdp enable
!

3. Просмотр результата
#sh queueing custom

Current custom queue configuration:

List Queue Args -
1 3 default -
1 1 protocol ip list 110
1 2 protocol ip list 120
1 1 byte-count 1000 -
1 2 byte-count 1000 -
1 3 byte-count 2000 -

#sh interface FastEthernet0/0

Queueing strategy: custom-list 1

#sh queueing interface fastEthernet 0/0
Interface FastEthernet0/0 queueing strategy: custom

Output queue utilization (queue/count)
 0/90 1/0 2/364 3/0 4/0 5/0 6/0 7/0 8/0
 9/0 10/0 11/0 12/0 13/0 14/0 15/0 16/0

3.2.3.4. WFQ. Взвешенные справедливые очереди.

Weighted Fair Queuing (WFQ) автоматически разбивает трафик на потоки (flows). По умолчанию их число равно 256, но может быть изменено (параметр dynamic-queues в команде fair-queue). Если потоков больше, чем очередей, то в одну очередь помещается несколько потоков. Принадлежность пакета к потоку (классификация) определяется на основе TOS, протокола, IP адреса источника, IP адреса назначения, порта источника и порта назначения. Каждый поток использует отдельную очередь.

Обработчик WFQ (scheduler) обеспечивает равномерное (fair - честное) разделение полосы между существующими потоками. Для этого доступная полоса делится на число потоков и каждый получает равную часть. Кроме того, каждый поток получает свой вес (weight), с некоторым коэффициентом обратно пропорциональный IP приоритету (TOS). Вес потока также учитывается обработчиком.

В итоге WFQ а втоматически справедливо распределяет доступную пропускную способность, дополнительно учитывая TOS. Потоки с одинаковыми IP приоритетами TOS получат равные доли полосы пропускания; потоки с большим IP приоритетом – большую долю полосы. В случае перегрузок ненагруженные высокоприоритетные потоки функционируют без изменений, а низкоприоритетные высоконагруженные – ограничиваются.

Вместе с WFQ работает RSVP. По умолчанию WFQ включается на низкоскоростных интерфейсах.

Алгоритм настройки.
1. Помечаем трафик каким-либо способом (устанавливаем IP приоритет - TOS) или получаем его помеченным

2. Включаем WFQ на интерфейсе
interface FastEthernet0/0
 fair-queue

interface FastEthernet0/0
 fair-queue CONGESTIVE_DISCARD_THRESHOLD DYNAMIC_QUEUES

Параметры:
CONGESTIVE_DISCARD_THRESHOLD – число пакетов в каждой очереди, при превышении которого пакеты игнорируются (по умолчанию - 64)
DYNAMIC_QUEUES – число подочередей, по которым классифицируется трафик (по умолчанию - 256)

3. Просмотр результата
# sh queueing fair
# sh queueing interface FastEthernet0/0

3.2.3.5. CBWFQ.

Class Based Weighted Fair Queuing (CBWFQ) соответствует механизму обслуживания очередей на основе классов. Весь трафик разбивается на 64 класса на основании следующих параметров: входной интерфейс, аксесс лист (access list), протокол, значение DSCP, метка MPLS QoS.

Общая пропускная способность выходного интерфейса распределяется по классам. Выделяемую каждому классу полосу пропускания можно определять как в абсолютное значение (bandwidth в kbit/s) или в процентах (bandwidth percent) относительно установленного значения на интерфейсе.

Пакеты, не попадающие в сконфигурированные классы, попадают в класс по умолчанию, который можно дополнительно настроить и который получает оставшуюся свободной полосу пропускания канала. При переполнении очереди любого класса пакеты данного класса игнорируются. Алгоритм отклонения пакетов внутри каждого класса можно выбирать: включенное по умолчанию обычное отбрасывание (tail-drop, параметр queue-limit) или WRED (параметр random-detect). Только для класса по умолчанию можно включить равномерное ( честное ) деление полосы (параметр fair-queue).

CBWFQ поддерживает взаимодействие с RSVP.

Параметры команды.

критерии отбора пакетов классом:
class-map match-all CLASS
 match access-group
 match input-interface
 match protocol
 match ip dscp
 match ip rtp
 match mpls experimental

определение класса:

class CLASS
 bandwidth BANDWIDTH
 bandwidth percent BANDWIDTH_PERCENT
 queue-limit QUEUE-LIMIT
 random-detect

определение класса по умолчанию (default):

class class-default
 bandwidth BANDWIDTH
 bandwidth percent BANDWIDTH_PERCENT
 queue-limit QUEUE-LIMIT
 random-detect
 fair-queue

обозначения:
CLASS – название класса.
BANDWIDTH – минимальная полоса kbit/s, значение независимо от bandwidth на интерфейсе.
BANDWIDTH_PERCENT - процентное соотношение от bandwidth на интерфейсе.
QUEUE-LIMIT – максимальное количество пакетов в очереди.
random-detect – использование WRED.
fair-queue – равномерное деление полосы, только для класса по умолчанию

По умолчанию абсолютное значение Bandwidth в классе CBWFQ не может превышать 75% значение Bandwidth на интерфейсе. Это можно изменить командой max-reserved-bandwidth на интерфейсе.

Алгоритм настройки.

1. Распределение пакетов по классам - class-map
access-list 101 permit ip any any precedence critical

class-map match-all Class1
 match access-group 101

2. Описание правил для каждого класса - policy-map
policy-map Policy1
 class Class1
  bandwidth 100
  queue-limit 20
 class class-default
  bandwidth 50
  random-detect

3. Запуск заданной политики на интерфейсе - service-policy
interface FastEthernet0/0
 bandwidth 256
 service-policy output Policy1

4. Просмотр результата
#sh class Class1
#sh policy Policy1
#sh policy interface FastEthernet0/0

Пример 1.

Деление общей полосы по классам в процентном соотношении (40, 30, 20).
access-list 101 permit ip host 192.168.0.10 any
access-list 102 permit ip host 192.168.0.20 any
access-list 103 permit ip host 192.168.0.30 any

class-map match-all Platinum
 match access-group 101
class-map match-all Gold
 match access-group 102
class-map match-all Silver
 match access-group 103

policy-map Isp
 class Platinum
  bandwidth percent 40
 class Gold
  bandwidth percent 30
 class Silver
  bandwidth percent 20

interface FastEthernet0/0
 bandwidth 256
 service-policy output Isp

3.2.3.6. LLQ.

Low Latency Queuing (LLQ) – очередность с низкой задержкой. LLQ можно рассматривать как механизм CBWFQ с приоритетной очередью PQ (LLQ = PQ + CBWFQ).
PQ в LLQ позволяет обеспечить обслуживание чувствительного к задержке трафика. LLQ рекомендуется в случае наличия голосового (VoIP) трафика. Кроме того, он хорошо работает с видеоконференциями.

Алгоритм настройки.

1. Распределение пакетов по классам - Class-map
access-list 101 permit ip any any precedence critical

class-map match-all Voice
 match ip precedence 6
class-map match-all Class1
 match access-group 101

2. Описание правил для каждого класса - Policy-map

Аналогично CBWFQ, только для приоритетного класса (он один) указывается параметр priority.
policy-map Policy1
 class Voice
  priority 1000
 class Class1
  bandwidth 100
  queue-limit 20
 class class-default
  bandwidth 50
  random-detect

3. Запуск заданной политики на интерфейсе - Service-policy
interface FastEthernet0/0
 bandwidth 256
 service-policy output Policy1

Пример 1.
Относим класс Voice к PQ, а все остальное к CQWFQ.
!
class-map match-any Voice
 match ip precedence 5
!
policy-map Voice
 class Voice
  priority 1000
 class VPN
  bandwidth percent 50
 class class-default
  fair-queue 16
!
interface X
 Sevice-policy output Voice
!

Пример 2.
Дополнительно ограничиваем общую скорость для PQ в LLQ, чтобы он не монополизировал весь канал в случае неправильной работы.
!
class-map match-any Voice
 match ip precedence 5
!
policy-map Voice
 class Voice
  priority 1000
  police 1024000 32000 32000 conform-action transmit exceed-action drop
 class Vpn
  bandwidth percent 50
 class class-default
  fair-queue 16
!
interface FastEthernet0/0
 service-policy output Voice
!

Продолжение следует...

Автор статьи Эдуард Афонцев

Анонс

 

  • Знак качества. Cisco QoS для начинающих, часть 3. Edward Afontsev.

 

  • Оптический кросс из подручных материалов;
  • Узел 10-ти домов, как часть MAN;
  • Письмо про IPv6;
  • Восстанавливаем Linksys WRT54G;
  • Помехи на спектроанализаторе;
  • Фотография "Жизнь";
  • Зарисовки узлов разных провайдеров. Вечная тема (много фотографий гарантировано);
  • Традиционный пункт - ссылки на интересные места Сети. Присылайте письма - они очень нужны для обзоров. Обязательно сообщайте, нужна ли Ваша подпись, ссылка, или лучше обойтись без нее;
  • В "ужастиках" - давно обещанная "настоящая" страшилка на чердаке, слабонервным не смотреть.
От редакции: если у вас есть чем поделиться с коллегами по отрасли, приглашаем к сотрудничеству
Ссылка на материал, для размещения на сторонних ресурсах
/articles/reviews/15468/znak-kachestva-cisco-qos-dlya-nachinayuschih-ii.html

Обсудить на форуме

Оставлять комментарии могут только зарегистрированные пользователи

Зарегистрироваться