vk_logo twitter_logo facebook_logo googleplus_logo youtube_logo telegram_logo telegram_logo

Обзор коммутатора SNR-S4550-24XQ 4

Дата публикации: 21.12.2014
Количество просмотров: 7253
Автор:

В магазине shop.nag.ru появилась очередная новинка - 10G L3-коммутатор SNR-S4550-24XQ. Познакомимся с ним поближе.

Коммутатор SNR-S4550-24XQ имеет 24 порта 1/10G SFP+ и 2 порта 40G QSFP+. Он обладает широким L2-функционалом, а также работает на уровне L3, в том числе с поддержкой MPLS. SNR-S4550-24XQ может применяться на уровне ядра и агрегации,  операторов связи и корпоративных клиентов, а также в качестве TOR-коммутатора в дата-центрах.

SNR-S4550-24XQ предлагается по цене от 4490$, что совсем недорого за такое количество 10G-портов и поддерживаемый функционал.

На передней панели коммутатора расположены 24 порта 1/10G SFP+, 2 порта 40G QSFP+, консольный порт, выделенный порт для управления, а также USB-разьем.

Сзади расположены два hot-swap блока питания, резервируемых по схеме 1+1 и 5 модульных вентиляторов, резервируемых в схеме 4+1. Два AC блока питания входят в комплектацию коммутатора.

Коммутатор комплектуется всем необходимым, чтобы установить его в стойку и начать работу.

Рассмотрим коммутатор изнутри:

Монтаж платы сделан хорошо, в центре, за массивным радиатором расположен “мозг” коммутатора - чипсет Broadcom Trident. Аналогичный используется в коммутаторах Extreme x670 и Cisco Nexus. Чипсет имеет встроенную поддержку MPLS (VPLS, VPWS, L3 VPN), L3-маршрутизации, полностью неблокируемую архитектуру с низкими значениями latency.

Коммутатор SNR-S4550-24XQ имеет следующие характеристики:

  • 128K mac-address-table
  • 16K ipv4 routes
  • 255 VRF instances
  • поддержка Selective QinQ, MRRP/ERRP/EAPS;
  • multicast: IGMPv1/v2/v3 snooping, PIM-DM, PIM-SM, PIM-SSM, MSDP
  • L3 роутинг: RIP, OSPF, OSPFv3, BGP, Policy based Routing (PBR)
  • MPLS (VPN, VPLS, VPWS)

Протоколы динамической маршрутизации и функционал MPLS активируется  лицензией. (Внимание! При покупке коммутатора до  31 декабря 2014 года лицензия на  L3 и MPLS предоставляется бесплатно!)

L2-функционал

Сперва стоит отметить низкую задержку коммутации пакетов - не более 1,21 uSec при загрузке коммутатора на 100%. Тесты таблицы MAC-адресов на коллизии показали, что практически до 100% заполнения FDB, коллизий “маков” нет. 

Возможности QoS

SNR-S4550 имеет по 8 очередей на порт и поддерживает механизмы обработки очередей SPQ, WRR, WDRR, а также WRED (Weighted Random Early Detection). Каждую очередь на порту можно ограничить по занимаемой полосе. Коммутатор поддерживает ремаркинг меток COS и DSCP, полисининг и шейпинг пакетов на основании ACL.

Для работы в кольцевых топологиях, коммутатор поддерживает как традиционные протоколы Spanning Tree (MSTP 802.1s, RSTP 802.1w, STP 802.1D), так и более современные протоколы MRPP, EAPS, ERRP,  имеющие время сходимости менее 100 ms.

SNR-S4550 поддерживает 4 mirror-сессии. Зеркалируемые пакеты можно фильтровать при помощи acl (на основании L2, L3, L4 заголовков пакетов).

Командой  "hardware profile module 1 4x10G" можно превратить 40G интерфейс в 4 порта по 10G, получив таким образом до 32 10G-портов на коммутаторе. Для этого в  40G  порт необходимо установить модуль типа SNR-QSFP-40G-4xSFP+DAC-3 или SNR-QSFP-40G-4xSFP+SR-5.

SNR-S4550 поддерживает трансляцию тега vlan на порту, для этого необходимо выполнить следующие команды:

vlan-translation enable
vlan-translation 300 to 20 in
vlan-translation 20 to 300 out

На остальном L2-функционале, таком как strom-control, igmp snooping, MVR, dhcp snooping и.т.п. я подробно останавливаться не буду, он работает аналогично другим моделям коммутаторов SNR.

L3-функционал

Для примера настроим SNR-S4550 в качестве L3-агрегации. Схема сети представлена ниже:

SNR-S4550 портом №24 подключается к вышестоящему маршрутизатору. С ним же поднимается OSFP-сессии. Для того чтобы изолировать сеть управления от остального трафика, поместим её в отдельный VRF mng. Для прохождения  мультикаст-трафика будем использовать PIM-SM. Предполагаемая схема работы на доступе - vlan на коммутатор. Поэтому, чтобы не создавать много отдельных интерфейсов, будем использовать функционал supervlan.

Проверяем версию прошивки:

SNR-S4550-24XQ-AC#sh ver
SNR-S4550-24XQ-AC Device, Compiled on Aug 12 20:40:07 2014
SoftWare Package Version 7.0.3.0(R0056.0065)
BootRom Version 7.2.3
HardWare Version 1.0.1
CPLD Version 0.5
Serial No.:SW042310E904000004
Copyright (C) 2014 NAG LLC
All rights reserved
Last reboot is warm reset.
Uptime is 0 weeks, 0 days, 0 hours, 0 minutes

На момент написания обзора, прошивка установлена самая свежая и обновление не требуется. Все новые прошивки для коммутаторов SNR находятся здесь.

Создаем vlan-ы 10,20 для связи с вышестоящим маршрутизатором, клиентские vlan 100-200, supervlan 1000 и vrf для управления:

vlan 10;15;100-400
!
vlan 1000
  supervlan
  subvlan 100-200
!
ip vrf mng
  description Management

Настроим аплинк-порт.

Interface Ethernet1/0/24
switchport mode trunk
switchport trunk allowed vlan 10;15

Создаем p2p и loopback-интерфейсы:

interface Vlan10
ip vrf forwarding mng
ip address 10.10.1.2 255.255.255.252
!
interface Vlan15
ip address 85.195.1.2 255.255.255.252
!
interface Loopback1
ip vrf forwarding mng
ip address 10.1.1.2 255.255.255.255
!
interface Loopback2
ip address 85.195.10.2 255.255.255.255

Настраиваем OSPF для глобальной таблицы маршрутизации и для VRF mng:

router ospf 1
ospf router-id 85.195.10.2
network 85.195.1.0/30 area 1
redistribute connected
redistribute static
!
router ospf 2 mng
ospf router-id 10.1.1.2
network 10.10.1.0/30 area 1
redistribute connected
redistribute static
!

Проверяем, что OSPF поднялся:

SNR-S4550-24XQ-AC#sh ip ospf 1 neighbor
OSPF process 1:
Neighbor   ID Pri   State        Dead    Time   Address      Interface
85.195.10.1          1   Full/Backup 00:00:30 85.195.1.1      Vlan15

SNR-S4550-24XQ-AC#sh ip ospf 2 neighbor
OSPF process 2:
Neighbor ID Pri   State        Dead Time   Address      Interface
10.1.1.1            1   Full/Backup 00:00:30 10.10.1.1    Vlan10

Создаем L3-интерфейс, на котором будут терминироваться клиенты:

interface Vlan1000
ip address 85.195.20.1 255.255.255.0

Создадим интерфейс для сети управления нижестоящими коммутаторами:

interface Vlan5
ip vrf forwarding mng
ip address 192.168.101.1 255.255.255.0

Ограничим доступ к консоли SNR-S4550 при помощи acl:

ip access-list standard cli_acl
permit 10.10.0.0 0.0.255.255
permit 85.195.2.0 0.0.0.255
exit    
authentication ip access-class cli_acl in

Настроим порты в сторону сети доступа. Если в порт установлен SFP-модуль вместо SFP+, необходимо указать скорость на интерфейсе.

Interface Ethernet1/0/1
switchport mode trunk
switchport trunk allowed vlan 5;100-120
!
Interface Ethernet1/0/2
switchport mode trunk
switchport trunk allowed vlan 5;121-140
speed-duplex force1g-full

Настроим прохождение мультикаста. Предполагаем, что на коммутаторах доступа включен MVR и он будет приходить в одном Vlan 25.

ip pim multicast-routing
ip pim rp-address 85.195.10.1
intferace vlan 15
ip pim sparse-mode
!
vlan 25
name multicast
!
interface vlan25
ip address 192.168.254.1 255.255.255.252
ip pim sparse-mode passive

Добавляем vlan с мультикаст-трафиком на порты, а также включаем фильтрацию пакетов igmp query:

int eth1/0/1-2
switchport trunk allowed vlan add 25

Включаем igmp-snooping:

ip igmp snooping
ip igmp snooping vlan 25

Настройка окончена. Если у вас появились вопросы по коммутатору SNR-S4550, можете задавать их на нашем форуме, либо через менеджера. Возможна организация удаленного доступа к SNR-S4550, установленного у нас на стенде или получение оборудования в тест.

Во второй части обзора мы подробно рассмотрим возможности функционала MPLS коммутатора SNR-S4550-24XQ.  

От редакции: если у вас есть чем поделиться с коллегами по отрасли, приглашаем к сотрудничеству
Ссылка на материал, для размещения на сторонних ресурсах
/articles/article/26679/obzor-kommutatora-snr-s4550-24xq.html

Обсудить на форуме

Оставлять комментарии могут только зарегистрированные пользователи

Зарегистрироваться